System Slowness
Incident Report for
SalonBiz
Resolved
The earlier reports of system slowness have been resolved. Everything is now fully operational. Thank you for your patience.
Posted
Apr
22
,
2025
-
11:48
CDT
Investigating
We are getting reports of system slowness. Our team is actively working to resolve any issues. We’ll continue to post updates as we investigate.
Posted
Apr
22
,
2025
-
11:16
CDT
This incident affected: SalonBiz.
×
Subscribe to Incident
Subscribe to updates for
System Slowness
via . You'll receive .